Export Method (String, String, ICollection(ElementId), DXFExportOptions)


Document Export(String, String, ICollection Element Id , DXFExport Options) Method

Exports a selection of views in DXF format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Export(
	string folder,
	string name,
	ICollection<ElementId> views,
	DXFExportOptions options
)

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
views ICollection ElementId
Selection of views to be exported. The set must contain at least one valid view.
options DXFExportOptions
Various options applicable to the DXF format. If , all options will be set to their respective default values.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception Condition
ArgumentException NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- some of the views are not printable (exportable). -or- Thrown when the options in DWGExportOptions is invalid.
ArgumentNullException A non-optional argument was null
DirectoryNotFoundException Thrown when the directory does not exist.
InvalidOperationException Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException The folder does not exist.
OptionalFunctionalityNotAvailableException The DXF module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.
Remarks
All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.
See Also