Triangle |
This class represents a triangle in a TriangulatedShellComponent object. The triangle is defined by its vertices, which are specified by their indices in the TriangulatedShellComponent's array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The TriangleInShellComponent type exposes the following members.

Name | Description | |
---|---|---|
![]() | TriangleInShellComponent | Creates a copy of the given TriangleInShellComponent |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | VertexIndex0 | Index of the triangle's first vertex in the TriangulatedShellComponent's array of vertices. |
![]() | VertexIndex1 | Index of the triangle's second vertex in the TriangulatedShellComponent's array of vertices. |
![]() | VertexIndex2 | Index of the triangle's third vertex in the TriangulatedShellComponent's array of vertices. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the TriangleInShellComponent |

A TriangulatedShellComponent stores an array of TriangleInShellComponent objects representing the triangles of the triangulation. An external class is used because the API does not allow the use of a triple of integers. Note that a TriangleInShellComponent must only be used in the context of a single, fixed TriangulatedShellComponent.