TriangleInShellComponent Class


Triangle In Shell Component Class

This class represents a triangle in a TriangulatedShellComponent object. The triangle is defined by its vertices, which are specified by their indices in the TriangulatedShellComponent's array of vertices.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TriangleInShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TriangleInShellComponent : IDisposable

The TriangleInShellComponent type exposes the following members.

Constructors
Name Description
Public method TriangleInShellComponent Creates a copy of the given TriangleInShellComponent
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property VertexIndex0 Index of the triangle's first vertex in the TriangulatedShellComponent's array of vertices.
Public property VertexIndex1 Index of the triangle's second vertex in the TriangulatedShellComponent's array of vertices.
Public property VertexIndex2 Index of the triangle's third vertex in the TriangulatedShellComponent's array of vertices.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the TriangleInShellComponent
Top
Remarks
A TriangulatedShellComponent stores an array of TriangleInShellComponent objects representing the triangles of the triangulation. An external class is used because the API does not allow the use of a triple of integers. Note that a TriangleInShellComponent must only be used in the context of a single, fixed TriangulatedShellComponent.
See Also