ResetActiveTemplate Method


IFCCategory Template Reset Active Template Method

Removes the information about active mapping temple of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static void ResetActiveTemplate(
	Document document
)

Parameters

document Document
The document to set.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
After calling this method, the active template of the document will be , which means that in-session template should be used.
See Also