IFCCategory
|
Represents an element that contains an IFC category mapping template stored in a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The IFCCategoryTemplate type exposes the following members.

Name | Description | |
---|---|---|
![]() |
IFCCategoryTemplate | Custom constructor for this element. |

Name | Description | |
---|---|---|
![]() |
AssemblyInstanceId |
The id of the assembly instance to which the element belongs.
(Inherited from Element ) |
![]() |
BoundingBox |
Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element ) |
![]() |
Category |
Retrieves a Category object that represents the category or sub category in which the
element resides.
(Inherited from Element ) |
![]() |
CreatedPhaseId |
Id of a Phase at which the Element was created.
(Inherited from Element ) |
![]() |
DemolishedPhaseId |
Id of a Phase at which the Element was demolished.
(Inherited from Element ) |
![]() |
DesignOption |
Returns the design option to which the element belongs.
(Inherited from Element ) |
![]() |
Document |
Returns the Document in which the Element resides.
(Inherited from Element ) |
![]() |
Geometry |
Retrieves the geometric representation of the element.
(Inherited from Element ) |
![]() |
GroupId |
The id of the group to which an element belongs.
(Inherited from Element ) |
![]() |
Id |
A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element ) |
![]() |
IsModifiable |
Identifies if the element is modifiable.
(Inherited from Element ) |
![]() |
IsTransient |
Indicates whether an element is transient or permanent.
(Inherited from Element ) |
![]() |
IsValidCategoryMappingFile | Whether or not the category mapping file is valid. |
![]() |
IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element ) |
![]() |
LevelId |
The id of the level associated with the element.
(Inherited from Element ) |
![]() |
Location |
This property is used to find the physical location of an element within a project.
(Inherited from Element ) |
![]() |
Name |
A human readable name for the Element.
(Inherited from Element ) |
![]() |
OwnerViewId |
The id of the view that owns the element.
(Inherited from Element ) |
![]() |
Parameter BuiltInParameter |
Retrieves a parameter from the element given a parameter id.
(Inherited from Element ) |
![]() |
Parameter Definition |
Retrieves a parameter from the element based on its definition.
(Inherited from Element ) |
![]() |
Parameter Guid |
Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element ) |
![]() |
Parameters |
Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element ) |
![]() |
ParametersMap |
Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element ) |
![]() |
Pinned |
Identifies if the element has been pinned to prevent changes.
(Inherited from Element ) |
![]() |
UniqueId |
A stable unique identifier for an element within the document.
(Inherited from Element ) |
![]() |
VersionGuid |
Get the element version Guid.
(Inherited from Element ) |
![]() |
ViewSpecific |
Identifies if the element is owned by a view.
(Inherited from Element ) |
![]() |
WorksetId |
Get Id of the Workset which owns the element.
(Inherited from Element ) |

Name | Description | |
---|---|---|
![]() |
ArePhasesModifiable |
Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element ) |
![]() |
CanBeHidden |
Indicates if the element can be hidden in the view.
(Inherited from Element ) |
![]() |
CanBeLocked |
Identifies if the element can be locked.
(Inherited from Element ) |
![]() |
CanDeleteSubelement |
Checks if given subelement can be removed from the element.
(Inherited from Element ) |
![]() |
CanHaveTypeAssigned |
Identifies if the element can have a type assigned.
(Inherited from Element ) |
![]() |
ChangeTypeId(ElementId) |
Changes the type of the element.
(Inherited from Element ) |
![]() |
CopyTemplate | Create copy of mapping template with new name. |
![]() ![]() |
Create | Create a IFC category mapping template with default values. |
![]() |
DeleteEntity |
Deletes the existing entity created by %schema% in the element
(Inherited from Element ) |
![]() |
DeleteSubelement |
Removes a subelement from the element.
(Inherited from Element ) |
![]() |
DeleteSubelements |
(Inherited from Element ) |
![]() |
Dispose |
(Inherited from Element ) |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
EvaluateAllParameterValues |
Evaluates all the parameters' values of the element.
(Inherited from Element ) |
![]() |
EvaluateParameterValues |
(Inherited from Element ) |
![]() |
ExportToFile | Export mapping template to a text file. |
![]() ![]() |
FindByName | Returns mapping template element by name. |
![]() ![]() |
GetActiveTemplate | Gets the active mapping template element in the document. |
![]() |
GetCategoryMappingTable | Gets the table that contains a mapping from Revit categories to IFC entities. |
![]() |
GetDependentElements |
Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element ) |
![]() |
GetEntity |
Returns the existing entity corresponding to the Schema if it has been saved in the
Element, or an invalid entity otherwise.
(Inherited from Element ) |
![]() |
GetEntitySchemaGuids |
Returns the Schema guids of any Entities stored in this element.
(Inherited from Element ) |
![]() |
GetExternalFileReference |
Gets information pertaining to the external file referenced
by the element.
(Inherited from Element ) |
![]() |
GetExternalResourceReference |
Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element ) |
![]() |
GetExternalResourceReferenceExpanded |
Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element ) |
![]() |
GetExternalResourceReferences |
Gets the map of the external resource references referenced
by the element.
(Inherited from Element ) |
![]() |
GetExternalResourceReferencesExpanded |
Gets the expanded map of the external resource references referenced
by the element.
(Inherited from Element ) |
![]() |
GetGeneratingElementIds |
Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element ) |
![]() |
GetGeometryObjectFromReference |
Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetMappingInfoById | Gets a copy of IFC mapping info by category id. |
![]() |
GetMaterialArea |
Gets the area of the material with the given id.
(Inherited from Element ) |
![]() |
GetMaterialIds |
Gets the element ids of all materials present in the element.
(Inherited from Element ) |
![]() |
GetMaterialVolume |
Gets the volume of the material with the given id.
(Inherited from Element ) |
![]() |
GetMonitoredLinkElementIds |
Provides the link instance IDs when the element is monitoring.
(Inherited from Element ) |
![]() |
GetMonitoredLocalElementIds |
Provides the local element IDs when the element is monitoring.
(Inherited from Element ) |
![]() ![]() |
GetOrCreateInSessionTemplate | Gets the in-session non-serializable template or create new. |
![]() |
GetOrderedParameters |
Gets the parameters associated to the element in order.
(Inherited from Element ) |
![]() |
GetParameter |
Retrieves a parameter from the element given identifier.
(Inherited from Element ) |
![]() |
GetParameterFormatOptions |
Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element ) |
![]() |
GetParameters |
Retrieves the parameters from the element via the given name.
(Inherited from Element ) |
![]() |
GetPhaseStatus |
Gets the status of a given element in the input phase
(Inherited from Element ) |
![]() |
GetSubelements |
Returns the collection of element subelements.
(Inherited from Element ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
GetTypeId |
Returns the identifier of this element's type.
(Inherited from Element ) |
![]() |
GetValidTypes |
Obtains a set of types that are valid for this element.
(Inherited from Element ) |
![]() |
HasPhases |
Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element ) |
![]() ![]() |
ImportFromFile | Import mapping template from a text file. |
![]() |
IsCreatedPhaseOrderValid |
Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element ) |
![]() |
IsDemolishedPhaseOrderValid |
Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element ) |
![]() |
IsExternalFileReference |
Determines whether this Element represents an external
file.
(Inherited from Element ) |
![]() |
IsHidden |
Identifies if the element has been permanently hidden in the view.
(Inherited from Element ) |
![]() |
IsMonitoringLinkElement |
Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element ) |
![]() |
IsMonitoringLocalElement |
Indicate whether an element is monitoring other local elements.
(Inherited from Element ) |
![]() |
IsPhaseCreatedValid |
Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element ) |
![]() |
IsPhaseDemolishedValid |
Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element ) |
![]() ![]() |
IsValidName | Returns result that the proposed name is valid and not exist in the specified document. |
![]() |
IsValidType(ElementId) |
Checks if given type is valid for this element.
(Inherited from Element ) |
![]() ![]() |
ListNames | Returns a list of names of IFC export mapping templates. |
![]() |
LookupParameter |
Attempts to find a parameter on the element which has the given name.
(Inherited from Element ) |
![]() |
RefersToExternalResourceReference |
Determines whether this Element uses external resources associated with
a specified external resource type.
(Inherited from Element ) |
![]() |
RefersToExternalResourceReferences |
Determines whether this Element uses external resources.
(Inherited from Element ) |
![]() ![]() |
ResetActiveTemplate | Removes the information about active mapping temple of the document. |
![]() |
ResetCategoryToDefault | Reset one category, sub-category, or special category in the current mapping table to the default values defined in Revit |
![]() |
SetActiveTemplate | Sets the mapping template element to be the active mapping template for its document. |
![]() |
SetActiveTemplate(Document) |
Obsolete.
Sets the mapping template element to be the active mapping template in the document. |
![]() |
SetEntity |
Stores the entity in the element. If an Entity described by the same Schema already
exists, it is overwritten.
(Inherited from Element ) |
![]() |
SetMappingInfo(IDictionary ExportIFCCategoryKey, ExportIFCCategoryInfo ) | |
![]() |
SetMappingInfo(ExportIFCCategoryKey, ExportIFCCategoryInfo) | Set the mapping info for the key. |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |
![]() |
UpdateCategoryList | Updates the mapping table with the categories from the document. |