KeyBasedTreeEntryError Class


Key Based Tree Entry Error Class

This class contains information about a problem encountered while creating a KeyBasedTreeEntries object.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB KeyBasedTreeEntryError

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class KeyBasedTreeEntryError : IDisposable

The KeyBasedTreeEntryError type exposes the following members.

Properties
Name Description
Public property ErrorType Indicates which of possible types of problems with loading and/or building a KeyBasedTreeEntries that this KeyBasedTreeEntryError represents.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the KeyBasedTreeEntryError
Public method GetEntry Gets the entry for which an error occurred while building the KeyBasedTreeEntries object.
Top
Remarks
This problem might be a duplicate entry, or an error in the specified parent-child relationships, or something else. See BuiltInKeyBasedTreeEntryErrorType for details.
See Also