ImportFromFile Method


IFCParameter Template Import From File Method

Import mapping template from a text file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static IFCParameterTemplate ImportFromFile(
	Document document,
	string fileName,
	string templateName
)

Parameters

document Document
The Revit document.
fileName String
The full text file name.
templateName String
The mapping template name.

Return Value

IFCParameterTemplate
The mapping template element.
Exceptions
Exception Condition
ArgumentException The name already exists.
ArgumentNullException A non-optional argument was null
FileAccessException Failed to access the text file.
InvalidOperationException Failed to create IFCParameterTemplate.
Remarks
The imported template is saved in the document passed as parameter. The active template of the document remains unchanged.
See Also