IFCParameter
|
Represents an element that contains an IFC parameter mapping template stored in a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The IFCParameterTemplate type exposes the following members.

Name | Description | |
---|---|---|
![]() |
IFCParameterTemplate | Custom constructor for this element. |

Name | Description | |
---|---|---|
![]() |
AssemblyInstanceId |
The id of the assembly instance to which the element belongs.
(Inherited from Element ) |
![]() |
BoundingBox |
Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element ) |
![]() |
Category |
Retrieves a Category object that represents the category or sub category in which the
element resides.
(Inherited from Element ) |
![]() |
CreatedPhaseId |
Id of a Phase at which the Element was created.
(Inherited from Element ) |
![]() |
DemolishedPhaseId |
Id of a Phase at which the Element was demolished.
(Inherited from Element ) |
![]() |
DesignOption |
Returns the design option to which the element belongs.
(Inherited from Element ) |
![]() |
Document |
Returns the Document in which the Element resides.
(Inherited from Element ) |
![]() |
ExportIFCBaseQuantities | The option to export IFC base quantities for exported Revit elements. If true, then all IFC base quantities not excluded will be exported. If false, then no IFC base quantities will be exported. |
![]() |
ExportIFCCommonPropertySets | The option to export IFC common property sets for exported Revit elements. If true, then all IFC Common Property Sets not excluded will be exported. If false, then no IFC Common Property Sets will be exported. |
![]() |
ExportRevitElementParameters | The option to export Revit element parameters to IFC. If true, then all Revit element parameters not excluded will be exported. If false, then no Revit element parameters will be exported. |
![]() |
ExportRevitMaterialParameters | The option to export Revit material parameters to IFC. If true, then all Revit material parameters not excluded will be exported. If false, then no Revit material parameters will be exported. |
![]() |
ExportRevitSchedules | The option to export Revit schedules to IFC. If true, then all Revit schedules not excluded will be exported. If false, then no Revit schedules will be exported. |
![]() |
ExportUserDefinedPropertySets | The option to export user-defined property sets. If true, then all user-defined property sets not excluded will be exported. If false, then no user-defined property sets will be exported. |
![]() |
Geometry |
Retrieves the geometric representation of the element.
(Inherited from Element ) |
![]() |
GroupId |
The id of the group to which an element belongs.
(Inherited from Element ) |
![]() |
Id |
A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element ) |
![]() |
IsModifiable |
Identifies if the element is modifiable.
(Inherited from Element ) |
![]() |
IsTransient |
Indicates whether an element is transient or permanent.
(Inherited from Element ) |
![]() |
IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element ) |
![]() |
IsValidParameterMappingFile | Whether or not the parameter mapping file is valid. |
![]() |
LevelId |
The id of the level associated with the element.
(Inherited from Element ) |
![]() |
Location |
This property is used to find the physical location of an element within a project.
(Inherited from Element ) |
![]() |
Name |
A human readable name for the Element.
(Inherited from Element ) |
![]() |
OwnerViewId |
The id of the view that owns the element.
(Inherited from Element ) |
![]() |
Parameter BuiltInParameter |
Retrieves a parameter from the element given a parameter id.
(Inherited from Element ) |
![]() |
Parameter Definition |
Retrieves a parameter from the element based on its definition.
(Inherited from Element ) |
![]() |
Parameter Guid |
Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element ) |
![]() |
Parameters |
Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element ) |
![]() |
ParametersMap |
Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element ) |
![]() |
Pinned |
Identifies if the element has been pinned to prevent changes.
(Inherited from Element ) |
![]() |
UniqueId |
A stable unique identifier for an element within the document.
(Inherited from Element ) |
![]() |
VersionGuid |
Get the element version Guid.
(Inherited from Element ) |
![]() |
ViewSpecific |
Identifies if the element is owned by a view.
(Inherited from Element ) |
![]() |
WorksetId |
Get Id of the Workset which owns the element.
(Inherited from Element ) |

Name | Description | |
---|---|---|
![]() |
AddPropertyMappingInfo | Adds a property mapping info to the property set. |
![]() |
AddPropertySet | Adds a property set to the template. |
![]() |
ArePhasesModifiable |
Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element ) |
![]() |
CanBeHidden |
Indicates if the element can be hidden in the view.
(Inherited from Element ) |
![]() |
CanBeLocked |
Identifies if the element can be locked.
(Inherited from Element ) |
![]() |
CanDeleteSubelement |
Checks if given subelement can be removed from the element.
(Inherited from Element ) |
![]() |
CanHaveTypeAssigned |
Identifies if the element can have a type assigned.
(Inherited from Element ) |
![]() |
ChangeTypeId(ElementId) |
Changes the type of the element.
(Inherited from Element ) |
![]() |
ClearPropertySets | Removes all property sets from the template. |
![]() |
CopyPropertySet | Creates a copy of the property set and adds it to the template. |
![]() |
CopyTemplate | Create copy of mapping template with new name. |
![]() ![]() |
Create | Create an IFC parameter mapping template with default values. |
![]() |
DeleteEntity |
Deletes the existing entity created by %schema% in the element
(Inherited from Element ) |
![]() |
DeleteSubelement |
Removes a subelement from the element.
(Inherited from Element ) |
![]() |
DeleteSubelements |
(Inherited from Element ) |
![]() |
Dispose |
(Inherited from Element ) |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
EvaluateAllParameterValues |
Evaluates all the parameters' values of the element.
(Inherited from Element ) |
![]() |
EvaluateParameterValues |
(Inherited from Element ) |
![]() |
ExportPropertySetupToFile | Exports mapping information of the provided property setup to a text file. |
![]() |
ExportToFile | Export mapping template to a text file. |
![]() ![]() |
FindByName | Returns mapping template element by name. |
![]() |
FindPropertyMappingInfo(PropertySetupType, String, ElementId) | Finds the property mapping info in the property set by id. |
![]() |
FindPropertyMappingInfo(PropertySetupType, String, String) | Finds the property mapping info in the property set by name. |
![]() ![]() |
GetActiveTemplate | Gets the active mapping template element in the document. |
![]() |
GetDependentElements |
Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element ) |
![]() |
GetEntity |
Returns the existing entity corresponding to the Schema if it has been saved in the
Element, or an invalid entity otherwise.
(Inherited from Element ) |
![]() |
GetEntitySchemaGuids |
Returns the Schema guids of any Entities stored in this element.
(Inherited from Element ) |
![]() |
GetExternalFileReference |
Gets information pertaining to the external file referenced
by the element.
(Inherited from Element ) |
![]() |
GetExternalResourceReference |
Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element ) |
![]() |
GetExternalResourceReferenceExpanded |
Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element ) |
![]() |
GetExternalResourceReferences |
Gets the map of the external resource references referenced
by the element.
(Inherited from Element ) |
![]() |
GetExternalResourceReferencesExpanded |
Gets the expanded map of the external resource references referenced
by the element.
(Inherited from Element ) |
![]() |
GetGeneratingElementIds |
Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element ) |
![]() |
GetGeometryObjectFromReference |
Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetMaterialArea |
Gets the area of the material with the given id.
(Inherited from Element ) |
![]() |
GetMaterialIds |
Gets the element ids of all materials present in the element.
(Inherited from Element ) |
![]() |
GetMaterialVolume |
Gets the volume of the material with the given id.
(Inherited from Element ) |
![]() |
GetMonitoredLinkElementIds |
Provides the link instance IDs when the element is monitoring.
(Inherited from Element ) |
![]() |
GetMonitoredLocalElementIds |
Provides the local element IDs when the element is monitoring.
(Inherited from Element ) |
![]() ![]() |
GetOrCreateInSessionTemplate | Gets the in-session non-serializable template or create new. |
![]() |
GetOrderedParameters |
Gets the parameters associated to the element in order.
(Inherited from Element ) |
![]() |
GetParameter |
Retrieves a parameter from the element given identifier.
(Inherited from Element ) |
![]() |
GetParameterFormatOptions |
Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element ) |
![]() |
GetParameters |
Retrieves the parameters from the element via the given name.
(Inherited from Element ) |
![]() |
GetPhaseStatus |
Gets the status of a given element in the input phase
(Inherited from Element ) |
![]() |
GetPropertyMappingInfos | Creates an array of property mappings contained in the property set according to provided selection type. |
![]() |
GetPropertySetApplicableEntities | Gets the list of IFC entities to which the property set is applicable. |
![]() |
GetPropertySetNames | Creates an array of property set names contained in the template according to provided selection type. |
![]() |
GetSubelements |
Returns the collection of element subelements.
(Inherited from Element ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
GetTypeId |
Returns the identifier of this element's type.
(Inherited from Element ) |
![]() |
GetValidTypes |
Obtains a set of types that are valid for this element.
(Inherited from Element ) |
![]() |
HasPhases |
Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element ) |
![]() ![]() |
ImportFromFile | Import mapping template from a text file. |
![]() |
ImportPropertySetupFromFile | Imports mapping information from a text file. |
![]() |
IsCreatedPhaseOrderValid |
Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element ) |
![]() |
IsDemolishedPhaseOrderValid |
Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element ) |
![]() |
IsExportingPropertySet | Determines whether the provided property set is included in export. |
![]() |
IsExternalFileReference |
Determines whether this Element represents an external
file.
(Inherited from Element ) |
![]() |
IsHidden |
Identifies if the element has been permanently hidden in the view.
(Inherited from Element ) |
![]() |
IsInSessionTemplate | Returns true if this is an in-session template. |
![]() |
IsMonitoringLinkElement |
Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element ) |
![]() |
IsMonitoringLocalElement |
Indicate whether an element is monitoring other local elements.
(Inherited from Element ) |
![]() |
IsPhaseCreatedValid |
Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element ) |
![]() |
IsPhaseDemolishedValid |
Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element ) |
![]() |
IsPropertySetAMemberOfTemplate | Checks whether a property set exists in the template. |
![]() ![]() |
IsValidName | Returns result that the proposed name is valid and not exist in the specified document. |
![]() |
IsValidType(ElementId) |
Checks if given type is valid for this element.
(Inherited from Element ) |
![]() ![]() |
ListNames | Returns a list of names of IFC export parameter mapping templates. |
![]() |
LookupParameter |
Attempts to find a parameter on the element which has the given name.
(Inherited from Element ) |
![]() |
RefersToExternalResourceReference |
Determines whether this Element uses external resources associated with
a specified external resource type.
(Inherited from Element ) |
![]() |
RefersToExternalResourceReferences |
Determines whether this Element uses external resources.
(Inherited from Element ) |
![]() |
RemovePropertyMappingInfo(PropertySetupType, String, ElementId) | Removes the property mapping from the property set by id. |
![]() |
RemovePropertyMappingInfo(PropertySetupType, String, String) | Removes the property mapping from the property set by name. |
![]() |
RemovePropertySet | Removes provided property set from the template. |
![]() ![]() |
ResetActiveTemplate | Removes the information about active mapping temple of the document. |
![]() |
SetActiveTemplate | Sets the mapping template element to be the active mapping template for its document. |
![]() |
SetEntity |
Stores the entity in the element. If an Entity described by the same Schema already
exists, it is overwritten.
(Inherited from Element ) |
![]() |
SetInSessionTemplateDocument | Set document for in-session template. |
![]() |
SetPropertySetApplicableEntities | |
![]() |
SetPropertySetExportingFlag | Define whether the provided property set must be included in export. |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |