Post |
The class is used as a base class for arguments of any post-event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.DB.Events PostEventArgs
Autodesk.Revit.DB.Events PostDocEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.DB.Events PostEventArgs
Autodesk.Revit.DB.Events PostDocEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PostEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs ) |
![]() | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs ) |
![]() | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |