PrimaryBarShapeId Property


Path Reinforcement Primary Bar Shape Id Property

The RebarShape element that defines the shape of the primary bars of the Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId PrimaryBarShapeId { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: shapeId should refer to two dimensional Rebar Shape element with segments forming only right angles, or the Rebar Shape has at least one end treatment or it has at least one crank.
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException When setting this property: This PathReinforcement does not host Rebar.
Remarks
Changing the value of this property causes the Path Reinforcement to choose values for its shape parameters.
See Also