Autodesk.Revit.DB.Structure Namespace


Autodesk. Revit. DB. Structure Namespace

Classes
Class Description
Public class AnalyticalElement Base class for a structural analytical elements. AnalyticalElement represents the analytical portion of a given Structural Element.
Public class AnalyticalLink An analytical link element that is used to create connections between other Analytical Elements.
Public class AnalyticalLinkType An object that specifies the analysis properties for an AnalyticalLink element.
Public class AnalyticalMember Represents a linear element in the structural analytical model.
Public class AnalyticalModelSelector Defines a portion of an Analytical Model for an Element.
Public class AnalyticalNodeData This class holds information related to analytical model.
Public class AnalyticalOpening An element that represents an Opening in an Analytical Panel element.
Public class AnalyticalPanel An element that represents a surface in the Structural Analytical Model.
Public class AnalyticalSurfaceBase This is the base class for analytical surface elements.
Public class AnalyticalToPhysicalAssociationManager Class which manages the associations between analytical elements and physical elements.
Public class AreaLoad An object that represents a force applied across an area.
Public class AreaLoadType AreaLoadType class
Public class AreaReinforcement An object that represents an Area Reinforcement within the Autodesk Revit project.
Public class AreaReinforcementCurve An object that specifies the type of a floor in Autodesk Revit.
Public class AreaReinforcementType An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.
Public class BarTerminationsData Class that stores data about reinforcement's terminations (e.g. hooks, cranks, end treatments)
Public class BendingDetailCustomFieldProperties Represents the properties of a Bending Detail Custom Field.
Public class BoundaryConditions An object that represents a force applied across an area.
Public class CodeCheckingParameterServiceData The data needed by code checking server to perform code checking.
Public class ConnectionInputPoint An object that holds information about a connection input point
Public class ConnectionInputPointInfo An object that holds description information about a connection input point
Public class EndTreatmentType An end treatment type object that is used to hold information about the end treatment applied to bars that are connected to a coupler.
Public class ExtElemChangeBeamSectionRegistry An object that stores IExtElemChangeBeamSection
Public class FabricArea An object that represents an Fabric Area Distribution within the Autodesk Revit project. It is container for Fabric Sheet elements.
Public class FabricAreaType A FabricAreaType object is used in FabricArea object generation.
Public class FabricReinSpanSymbol Represents an instance of a Structural Fabric Reinforcement Symbol in Autodesk Revit.
Public class FabricRoundingManager Provides access to element reinforcement roundings overrides.
Public class FabricSheet An object that represents an Fabric Sheet Element within the Autodesk Revit project.
Public class FabricSheetType Represents a fabric sheet type, used in the generation of fabric wires.
Public class FabricWireItem Provides implementation for FabricWires stored in a Custom Fabric Sheet
Public class FabricWireType A Fabric Wire Type object that is used in the generation of Fabric Wire.
Public class FamilyStructuralMaterialTypeFilter A filter used to match families that have the given structural material type.
Public class Hub Represents a connection between two or more Autodesk Revit Elements.
Public class LineLoad An object that represents a force/moment applied in a linear manner.
Public class LineLoadType LineLoadType class
Public class LoadBase The LoadBase object is the base class for all load objects within the Autodesk Revit API. Data members
Public class LoadCase An object that represents a load usage.
Public class LoadCombination An object that represents a load combination.
Public class LoadComponent An object that represents a load combination component.
Public class LoadNature An object that represents a load nature.
Public class LoadTypeBase The base class for LoadTypes
Public class LoadUsage An object that represents a load usage.
Public class MemberForces An object that represents a member forces on analytical element.
Public class MemberForcesServiceData The data needed by member forces server to perform type definition.
Public class PathReinforcement An object that represents an Path Reinforcement within the Autodesk Revit project.
Public class PathReinforcementType An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.
Public class PathReinSpanSymbol Represents a Path Reinforcement Span Symbol element in Autodesk Revit.
Public class PointLoad An object that represents a force/moment applied to a single point. Data members
Public class PointLoadType PointLoadType class
Public class Rebar Represents a rebar element in Autodesk Revit.
Public class RebarBarType A Rebar type object that is used in the generation of Rebar
Public class RebarBendData The values in this class provide a summary of information taken from the RebarBarType, RebarHookType, and RebarStyle.
Public class RebarBendingDetail Utility class with methods needed for the bending details in view. The bending detail element has two modes -- the schematic bending detail and realistic bending detail. Some functions are exclusive to one mode.
Public class RebarBendingDetailType Type for rebar bending detail elements.
Public class RebarConstrainedHandle A class representing a handle on a Rebar that can be joined to a reference, such as a host Element's surface or cover, another Rebar's handle or to a generic surface.
Public class RebarConstraint A class representing a constraint on a handle of a rebar element.
Public class RebarConstraintsManager A class used to obtain information about the constraints (RebarConstraint) acting on the shape handles (RebarConstrainedHandle) of a Rebar element, and modify the constraints.
Public class RebarContainer An object that represents an Rebar Container Element within the Autodesk Revit project.
Public class RebarContainerItem Provides implementation for Rebar stored in RebarContainer.
Public class RebarContainerIterator An iterator to a Rebar Container.
Public class RebarContainerParameterManager Provides implementation of RebarContainer parameters overrides.
Public class RebarContainerType Represents a Rebar Container Type, used in the generation of Rebar Container.
Public class RebarCoupler Represents a rebar coupler element in Autodesk Revit.
Public class RebarCoverType A named value for a clear cover distance.
Public class RebarCrankOverridableParameters Class used to store the formula parameter ids defined in the RebarShape family which are associated with crank length, crank offset length, crank straight length and crank angled length parameters.
Public class RebarCrankTypeUtils Utility class for dealing with Rebar Crank Type operations. To find all Rebar Crank Types in the document can be done using FilteredElementCollector of category BuiltInCategory.OST_RebarCrankType.
Public class RebarCurvesData The class that contains the information needed to calculate and return the result of the external curve generation.
Public class RebarFreeFormAccessor A class that is used to access the properties and capabilities of free-form Rebar.
Public class RebarFreeFormCreationResult Class that encapsulates the result of the rebar free form creation.
Public class RebarHandleNameData This class is used to contain the information about the rebar handle name defined by an external application.
Public class RebarHandlePositionData The class that contains data for the handle position calculation.
Public class RebarHandlesData This class is used to contain the information about the rebar handles defined by an external application.
Public class RebarHookType A Rebar Hook type object that is used in the generation of Rebar.
Public class RebarHostData Interface to rebar-specific data stored in each valid rebar host element.
Public class RebarInSystem Represents a rebar element that is part of a system.
Public class RebarPropagation An utility class containing functions that can be used to propagate rebar elements.
Public class RebarReinforcementData class containing the id and the end of rebar on which the coupler stays
Public class RebarRoundingManager Provides access to element reinforcement roundings overrides.
Public class RebarShape RebarShape specifies the shape type for a Rebar instance.
Public class RebarShapeConstraint A dimension or other constraint that takes part in a RebarShapeDefinition.
Public class RebarShapeConstraint180DegreeBendArcLength A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the arc length.
Public class RebarShapeConstraint180DegreeBendRadius A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the radius of the arc.
Public class RebarShapeConstraint180DegreeDefaultBend A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The arc's radius is not specified by the shape; instead it is a "default bend radius," taken from the RebarBarType associated with the Rebar instance.
Public class RebarShapeConstraintAngleFromFixedDir A constraint which can be applied to a RebarShapeSegment and drives the angle of the segment relative to a fixed direction in UV-space.
Public class RebarShapeConstraintArcLength An arc-length constraint associated with an arc in a RebarShapeDefinition.
Public class RebarShapeConstraintChordLength A constraint that can be applied to a RebarShapeDefinitionByArc and drives the straight distance between the arc endpoints.
Public class RebarShapeConstraintCircumference A circumference constraint associated with an arc in a RebarShapeDefinition.
Public class RebarShapeConstraintDiameter A diameter constraint associated with an arc in a RebarShapeDefinition.
Public class RebarShapeConstraintFixedSegmentDir A constraint that can be applied to a RebarShapeSegment and fixes the direction of the segment in UV-space.
Public class RebarShapeConstraintProjectedSegmentLength A constraint that measures the length of a segment as measured by projecting onto a direction that is not parallel to the segment.
Public class RebarShapeConstraintRadius A radius constraint associated with an arc in a RebarShapeDefinition.
Public class RebarShapeConstraintSagittaLength A constraint that can be applied to a RebarShapeDefinitionByArc and drives the height of the arc.
Public class RebarShapeConstraintSegmentLength A constraint that controls the length of a segment.
Public class RebarShapeDefinition A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition.
Public class RebarShapeDefinitionByArc Definition of a shape whose size and position can determined by a single arc.
Public class RebarShapeDefinitionBySegments Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.
Public class RebarShapeDrivenAccessor A class that is used to access the properties and capabilities of shape-driven Rebar.
Public class RebarShapeMultiplanarDefinition A specification for a simple 3D rebar shape.
Public class RebarShapeParameters Class containing functions that create and retrieve shared parameters for RebarShapes.
Public class RebarShapeSegment Part of a RebarShapeDefinitionBySegments, representing one segment of a shape definition. Makes sure constraints of type RebarShapeConstraintFixedSegmentDir are uniquely set. If we try to aquire a second constraint of type RebarShapeConstraintFixedSegmentDir we delete the old one.
Public class RebarShapeTerminationsData Class that stores data about rebar shape's terminations (e.g. hooks, cranks, end treatments)
Public class RebarShapeVertex A bend between segments of a rebar shape definition.
Public class RebarSplice A class that can used to access the data between two connected Rebars.
Public class RebarSpliceByRulesResult Class that encapsulates the result of the splice by rules operation.
Public class RebarSpliceGeometry This class consists of a vector and a point which will be projected to the nearest Rebar curve.
Public class RebarSpliceOptions This class encapsulates the options for the rebar splice operation.
Public class RebarSpliceRules Describes the rules for splicing Rebar.
Public class RebarSpliceTypeUtils Utility class for dealing with Rebar Splice Type operations. To find all Rebar Splice Types in the document can be done using FilteredElementCollector of category BuiltInCategory.OST_RebarSpliceType.
Public class RebarSpliceUtils Class with different utilities for Rebar Splice.
Public class RebarSystemSpanSymbol Represents a Rebar System Span Symbol element in Autodesk Revit.
Public class RebarTrimExtendData The class that contains the information needed to calculate and return the curves in a trimmed/extended state, and also find the constraints that trim/extend it.
Public class RebarUpdateCurvesData Class holding the information needed to calculate the rebar curves.
Public class ReinforcementAbbreviationTag This class is used to access the Area or Path Reinforcement abbreviation tag data. It stores abbreviation tag value and abbreviation type.
Public class ReinforcementData Abstract class for various reinforcement data
Public class ReinforcementRoundingManager A base class providing access to reinforcement rounding overrides for structural elements.
Public class ReinforcementSettings Provides access to project-wide reinforcement settings.
Public class ReleaseConditions An object that represents a Release Conditions on analytical element.
Public class StructuralConnectionApprovalType A type element that represents a connection approval type.
Public class StructuralConnectionHandler An object of Structural Connection Handler.
Public class StructuralConnectionHandlerType A StructuralConnectionHandlerType is used in StructuralConnectionHandler element generation.
Public class StructuralConnectionSettings Provides access to project-wide structural connections settings.
Public class StructuralConnectionType A type element that represents a connection symbol applied to structural members.
Public class StructuralFramingUtils A collection of Structural Framing Utilities.
Public class StructuralInstanceUsageFilter A filter used to find elements that are structural family instances (typically columns, beams or braces) of the given structural usage.
Public class StructuralMaterialTypeFilter A filter used to match family instances that have the given structural material type.
Public class StructuralSectionsServiceData The data needed by section type server to perform type definition.
Public class StructuralSettings Provides access to project-wide structural settings.
Public class StructuralWallUsageFilter A filter used to match walls that have the given structural wall usage.
Public class Truss Represents all kinds of Trusses.
Public class TrussMemberInfo Provides access to the information of a truss member in Autodesk Revit.
Public class TrussType Represents a specific type of truss.
Interfaces
Interface Description
Public interface ICodeCheckingParameterServer Interface for the code checking parameter server to implement.
Public interface IExtElemChangeBeamSection Interface Change Beam section functionality to be implemented in add-ins
Public interface IMemberForcesServer Interface for the Member Forces server to implement.
Public interface IRebarUpdateServer Represents an interface that should be overridden to allow the generation and update of free form rebar geometry.
Public interface IStructuralSectionsServer Interface for the section type parameter server to implement.
Enumerations
Enumeration Description
Public enumeration AlignedDistributionRebarHandles This enum represents the values that custom handles tags of RebarConstrainedHandle of Rebar Free Form Aligned Distribution has. The tag of a [!:Autodesk::Revit::DB::Structure::RebarHandleType::CustomHandle] RebarConstrainedHandle can be obtained by calling the [!:Autodesk::Revit::DB::Structure::RebarConstrainedHandle::GetCustomHandleTag()]
Public enumeration AlignedFreeFormSetOrientationOptions Orientation options for Aligned Free Form Rebar set.
Public enumeration AnalyticalCurveSelector Specifies which portion of an Analytical Curve is of interest.
Public enumeration AnalyticalElementSelector Specifies a portion of an Analytical Element or the whole element.
Public enumeration AnalyticalFixityState Specifies the fixity setting of individual degrees of freedom in analytical release conditions.
Public enumeration AnalyticalLoopType Specifies kind of analytical model loop.
Public enumeration AnalyticalNodeConnectionStatus Indicates the Connections Status for an Analytical Node.
Public enumeration AnalyticalRigidLinksOption Specifies how Rigid Links will be made for the Analytical Model.
Public enumeration AnalyticalStructuralRole Indicates the structural role for the analytical elements.
Public enumeration AnalyticalSupportPriority Defines how "highly" another Element is giving support for one Element.
Public enumeration AnalyticalSupportType Indicates what kind of support another Element provides -- Point, Surface, or Curve.
Public enumeration AnalyzeAs Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.
Public enumeration AreaReinforcementLayerType Describes the layers of an Area Reinforcement
Public enumeration BendingDetailAngularDimensionsDisplayOptions Describes the angular dimensions display options.
Public enumeration BendingDetailAngularDimensionsMeasurementOptions Describes the angular dimension measurement options.
Public enumeration BendingDetailBendDiameterDimensionType Describes the dimension type for bend diameter.
Public enumeration BendingDetailCustomFieldMultipleValuesIndicatorOptions Describes how the parameters with multiple values will be represented.
Public enumeration BendingDetailDimensionTextPosition Describes how the text will be positioned with respect to dimension line.
Public enumeration BendingDetailDisplayMode Describes the mode in which the Bending Detail will be represented.
Public enumeration BendingDetailDisplayParametersOptions Describes how the parameters will be represented.
Public enumeration BendingDetailFor3DShapesOptions Describes how the Bending Detail will be represented for 3D shapes.
Public enumeration BendingDetailLevelOfDetail Describes the level of detail in which the Bending Detail will be represented.
Public enumeration BendingDetailSegmentLengthsDisplayOptions Describes if the segment lengths are represented using dimensions or just as text.
Public enumeration BendingDetailSegmentsRepresentation Describes how the Bending Detail will represent the bar segments.
Public enumeration BendingDetailTypeMultipleValuesIndicatorOptions Describes how the parameters with multiple values will be represented.
Public enumeration BentFabricBendDirection Direction in which FabricSheet is bent.
Public enumeration BentFabricStraightWiresLocation Bent Fabric straight wires location. The side on wich straight wires will be loacted is determined by the start and end point of the first bent profile segment that specifies the direction of the curve loop on plane.
Public enumeration BoundaryConditionsOrientTo Specifies boundary condition orientation.
Public enumeration BoundaryConditionsType This enum declares type of BoundaryConditions.
Public enumeration BracePlanRepresentation The possible representations for braces in plan views.
Public enumeration FabricHostReference Controls if Single Fabric Sheet should be cut by the Host Cover.
Public enumeration FabricLapSplicePosition Fabric lap splice position in the fabric distribution
Public enumeration FabricLocation Fabric location in the host
Public enumeration FabricSheetAlignment Fabric Sheet alignment in the fabric distribution
Public enumeration FabricSheetLayoutPattern The pattern for how the wires in Fabric Sheet are laid out.
Public enumeration FabricTagComponentReference How FabricSheet tag text will be aligned to the FabricSheet symbol.
Public enumeration LoadCaseCategory Specifies load case category.
Public enumeration LoadCombinationState Specifies load combination state.
Public enumeration LoadCombinationType Specifies load combination type.
Public enumeration LoadOrientTo Specifies load orientation.
Public enumeration LoadType This enum declares types of Loads.
Public enumeration MultiplanarOption Input argument type for Rebar.GetCenterlineCurves method. Controls whether all curves of a multi-planar Rebar element are returned by GetCenterlineCurves, or only the curves in the primary plane.
Public enumeration RebarConstraintsStatus Describes the status of the constraints
Public enumeration RebarConstraintTargetHostFaceType A type to help identify the individual face on a host element to which a Rebar handle is constrained.
Public enumeration RebarConstraintType The various types of constraints that can be applied to a RebarConstrainedHandle.
Public enumeration RebarCouplerError Error states for the Rebar Coupler
Public enumeration RebarDeformationType Bar deformation type
Public enumeration RebarEndType Describes what is added at the end of a Rebar.
Public enumeration RebarFreeFormValidationResult Errors for the Free Form Rebar
Public enumeration RebarGeometryType Rebar geometry type
Public enumeration RebarHandleBehavior Different behaviors that can be applied to a RebarConstrainedHandle. Depending on the behavior, the RebarConstrainedHandle plane is situated in a different location All the data in constraints for a RebarConstrainedHandle with a specific behavior are relative to this plane.
Public enumeration RebarHandleType The various types of handles on a Rebar instance that can be joined to References
Public enumeration RebarHookOrientation Obsolete.
Orientation of a rebar hook relative to the path of the Rebar Shape.
Public enumeration RebarHostCategory Rebar host category
Public enumeration RebarLayoutRule The rule for how the rebars in rebar set are laid out
Public enumeration RebarPresentationMode Bar presentation mode
Public enumeration RebarShapeArcReferenceType A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account by specifying whether it measures to the exterior, centerline, or interior of the bend.
Public enumeration RebarShapeBendAngle A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.
Public enumeration RebarShapeDefinitionByArcType A RebarShapeDefinitionByArc takes one of three forms.
Public enumeration RebarShapeSegmentEndReferenceType A choice of two reference points for one end of a constraint driving the length of a RebarShapeSegment.
Public enumeration RebarShapeVertexTurn Specify whether a bend at a RebarShapeVertex represents a left or right turn.
Public enumeration RebarSpliceByRulesError Class that defines states for splicing a Rebar by rules.
Public enumeration RebarSpliceByRulesRunOutPosition Describes the run-out position.
Public enumeration RebarSpliceError Class that defines states for splicing a Rebar.
Public enumeration RebarSplicePosition Describes the position of the splice.
Public enumeration RebarSpliceShiftOption Describes the way bars are shifted in the splice relation.
Public enumeration RebarStyle Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.
Public enumeration RebarTerminationOrientation Orientation of a rebar termination (e.g hook, crank) relative to the path of the Rebar Shape.
Public enumeration RebarWorkInstructions Describes how a Free Form Rebar will be fabricated.
Public enumeration ReinforcementAbbreviationObjectType Defines the type of desired reinforcement object for abbreviation tags.
Public enumeration ReinforcementAbbreviationTagType Defines all types of abbreviation tags for Area and Path Reinforcement objects.
Public enumeration ReinforcementBarOrientation Describes the bar orientation at Path Reinforcement.
Public enumeration ReinforcementNumberingMethod Defines numbering method settings.
Public enumeration ReinforcementRoundingSource An enumerated type listing the possible sources for reinforcement rounding overrides.
Public enumeration ReleaseType The release type.
Public enumeration StirrupTieAttachmentType An enumerated tye that represents how the Stirrup/Tie rebar is attached to the cover reference.
Public enumeration StructuralConnectionApplyTo An enumerated type that represents the type of structural locations to which a connection annotation may be applied.
Public enumeration StructuralConnectionCodeCheckingStatus An enumerated type listing all code checking status of the structural connection element.
Public enumeration StructuralInstanceUsage Represents the structural usage of a family instance.
Public enumeration StructuralMaterialType Represents the structural material type. This enum value is returned by Autodesk::Revit::DB::FamilyInstance::StructuralMaterialType.
Public enumeration StructuralType Represents the structural type of a family instance.
Public enumeration StructuralWallUsage Represents the structural usage of a wall.
Public enumeration SurfaceDistributionRebarHandles This enum represents the values that custom handles tags of RebarConstrainedHandle of Rebar Free Form Surface Distribution has. The tag of a [!:Autodesk::Revit::DB::Structure::RebarHandleType::CustomHandle] RebarConstrainedHandle can be obtained by calling the [!:Autodesk::Revit::DB::Structure::RebarConstrainedHandle::GetCustomHandleTag()]
Public enumeration SurfaceElementExtension Presets for given Analytical Extension.
Public enumeration SurfaceElementProjectionZ Presets for given Analytical Projection Z.
Public enumeration TargetRebarConstraintType A type used to identify the particular part of a Stirrup style rebar to which a Standard style rebar's handle is constrained.
Public enumeration TranslationRotationValue Specifies the type of condition applied to the translation or rotation parameter.
Public enumeration TrussChordLocation This enumerated type represents the options for the Truss Chord Location.
Public enumeration TrussCurveType Types of curves created in truss families.
Public enumeration TrussMemberType Indicates the "kind" of a truss member.
Public enumeration WireDistributionDirection Defines the direction of the distribution of wires in a Fabric Sheet.
Public enumeration YJustification The justification of the framing element in Y.
Public enumeration YZJustificationOption The option for whether a framing element has independent or uniform justification on its ends.
Public enumeration ZJustification The justification of the framing element in Z.