AddBuildingStorey Method


Exporter IFC Add Building Storey Method

Note: This API is now obsolete.

Adds building storey to the exporter's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This is deprecated in Revit 2026.  Use ExporterCacheManager.LevelInfoCache.LevelsById instead.")]
public void AddBuildingStorey(
	ElementId id,
	IFCLevelInfo levelInfo
)

Parameters

id ElementId
The level id.
levelInfo IFCLevelInfo
The IFCLevelInfo object.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also