GetAutoCalculatedCrank Method


Rebar Bar Type Get Auto Calculated Crank Method

Identifies if the crank dimensions are auto calculated for the specified Rebar Crank Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool GetAutoCalculatedCrank(
	ElementId rebarCrankTypeId
)

Parameters

rebarCrankTypeId ElementId
The Rebar Crank Type id. Interactions with Rebar Crank Types can be done with the functions in [!:Autodesk::Revit::DB::Structure::RebarCrankTypeUtils] .

Return Value

Boolean
Returns true if the crank dimensions are auto calculated for the specified Rebar Bar Type and Rebar Crank Type, false otherwise.
Exceptions
Exception Condition
ArgumentException The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category.
ArgumentNullException A non-optional argument was null
See Also