CanCrankParametersBeComputedUsingCrankRatio Method


Rebar Bar Type Can Crank Parameters Be Computed Using Crank Ratio Method

Identifies if the all crank parameters can be computed for the specified crank ratio and Rebar Crank Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool CanCrankParametersBeComputedUsingCrankRatio(
	ElementId rebarCrankTypeId,
	double crankRatio
)

Parameters

rebarCrankTypeId ElementId
The Rebar Crank Type id. Interactions with Rebar Crank Types can be done with the functions in [!:Autodesk::Revit::DB::Structure::RebarCrankTypeUtils] .
crankRatio Double
The value of the crank ratio to be tested.

Return Value

Boolean
Returns true if the crank paramters can be computed using the input crank paramter, false otherwise.
Exceptions
Exception Condition
ArgumentException The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category.
ArgumentNullException A non-optional argument was null
Remarks
The crank slope is 1/crankRatio.
See Also