SetCutLineWeight Method


Override Graphic Settings Set Cut Line Weight Method

Sets the cut surface line weight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public OverrideGraphicSettings SetCutLineWeight(
	int lineWeight
)

Parameters

lineWeight Int32
Value of the cut surface line weight for the override. InvalidPenNumber means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception Condition
ArgumentException Line weight must be a positive integer less than 17 or invalidPenNumber.
See Also