GetCableTypeId Method


Cable Type Get Cable Type Id Method

Gets the Cable Type id by given cable type name.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static ElementId GetCableTypeId(
	Document document,
	string name
)

Parameters

document Document
The document.
name String
The Cable Type name.

Return Value

ElementId
The Cable Type id. InvalidElementId will be returned if no Cable Type by given name.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
See Also