Autodesk.Revit.DB.Electrical Namespace


Autodesk. Revit. DB. Electrical Namespace

Classes
Class Description
Public class AnalyticalBusData Represents the data and parameters of analytical bus node.
Public class AnalyticalDistributionNodePropertyData Represents the data and parameters of electrical analytical node.
Public class AnalyticalEquipmentLoadData Represents the data and parameters of point load node.
Public class AnalyticalPowerDistributableNodeData Represents the data and parameters of a power distributable node. A power distribution node is an electrical analytical node with a distribution system which defines the connection rules between upstream and downstream electrical analytical nodes.
Public class AnalyticalPowerSourceData Represents the data and parameters of analytical power source node.
Public class AnalyticalTransferSwitchData Represents the data and parameters of electrical analytical transfer switch.
Public class AnalyticalTransformerData Represents the data and parameters of analytical transformer node.
Public class AreaBasedLoadBoundaryLineData Wrapper class used to access area based load boundary line related data.
Public class AreaBasedLoadData Represents the electrical area based load data.
Public class AreaBasedLoadType This class represents an area based load type in Autodesk Revit.
Public class CableSize This class represents the definition of Cable Size data.
Public class CableTray This class represents a cable tray in Autodesk Revit.
Public class CableTrayConduitBase The CableTrayConduitBase class is implemented as the base class for cable tray or conduit
Public class CableTrayConduitRunBase The base class for a cable tray or conduit run in Autodesk Revit.
Public class CableTrayRun This class represents a cable tray run in Autodesk Revit.
Public class CableTraySettings The cable tray settings.
Public class CableTraySizeIterator An iterator to a set of MEP cable tray sizes from CableTraySizes.
Public class CableTraySizes Cable tray sizes.
Public class CableTrayType This class represents a cable tray type in Autodesk Revit.
Public class CableType This class represents a cable type.
Public class CircuitNamingScheme This class represents a circuit naming scheme in Autodesk Revit.
Public class CircuitNamingSchemeSettings This class represents a circuit naming scheme settings in Autodesk Revit.
Public class ConductorMaterial This class represents the definition of Conductor Material data.
Public class ConductorSize This class represents the definition of Conductor Size data.
Public class Conduit This class represents a conduit in Autodesk Revit.
Public class ConduitRun This class represents a conduit run in Autodesk Revit.
Public class ConduitSettings The conduit settings.
Public class ConduitSize Stores the basic size information for a conduit.
Public class ConduitSizeIterator An iterator to a set of conduit sizes from ConduitSizes.
Public class ConduitSizes Class ConduitSizeSet being used to store the conduit sizes.
Public class ConduitSizeSettingIterator An iterator to a set of items from ConduitSizeSettings. Each item is a KeyValuePair(System::String^, ConduitSizes). ElementId is the id of the conduit standard type.
Public class ConduitSizeSettings Conduit sizes settings
Public class ConduitType This class represents a conduit type in Autodesk Revit.
Public class CorrectionFactor Obsolete.
Represents electrical correction factor information.
Public class CorrectionFactorSet A set that contains correction factors.
Public class CorrectionFactorSetIterator An iterator to a correction factor set.
Public class DistributionSysType Represents a specific type of distribution system.
Public class DistributionSysTypeSet A set that contains DistributionSys types.
Public class DistributionSysTypeSetIterator An iterator to a DistributionSys type set.
Public class ElectricalAnalyticalLoadSet Represents the electrical analytical load set, it can contain a set of Electrical Analytical Equipment Loads.
Public class ElectricalAnalyticalNode Represents an electrical analytical node under the Analytical Power Distribution in the System Browser.
Public class ElectricalDemandFactorDefinition The ElectricalDemandFactorDef class represents a serialized version of an instance of demand factor definition. It has a name, rule type, and values for the rules that are serialized.
Public class ElectricalDemandFactorValue This class represents values used by a particular demand factor definition. Each instance corresponds to a row in a table of values. These values are part of the ElectricalDemandFactorDefinition class.
Public class ElectricalEquipment Provides access to the Electrical Equipment in Autodesk Revit.
Public class ElectricalLoadAreaData Represents the electrical load area data.
Public class ElectricalLoadClassification The ElectricalLoadClassification class represents a serialized version of an instance of load classification.
Public class ElectricalPerPhaseData This class represents per phase values including current and power.
Public class ElectricalSetting The ElectricalSetting class represents an instance of element of electrical settings.
Public class ElectricalSystem Provides access to the Electrical System in Autodesk Revit MEP.
Public class GroundConductorSize Obsolete.
Represents electrical ground conductor size definition information.
Public class GroundConductorSizeSet A set that contains GroundConductorSizes.
Public class GroundConductorSizeSetIterator An iterator to a GroundConductorSize set.
Public class InsulationMaterial This class represents the definition of Conductor Insulation Material data.
Public class InsulationType Obsolete.
Represents electrical insulation type definition information.
Public class InsulationTypeSet A set that contains insulation types.
Public class InsulationTypeSetIterator An iterator to a insulation type set.
Public class LightingDevice Provides access to the Lighting Device in Autodesk Revit MEP.
Public class LightingFixture Provides access to the Lighting Fixture in Autodesk Revit MEP.
Public class PanelScheduleData The PanelScheduleData class holds most of the data that describe the layout, appearance, and style of the rows, columns, and cells of a panel schedule
Public class PanelScheduleSheetInstance The class represents an instance of a panel schedule placed on sheet.
Public class PanelScheduleTemplate The PanelScheduleTemplate class represents an instance of panel schedule template element. An instance object could be a branch panel, a switchboard or a data panel template.
Public class PanelScheduleView An instance of a panel schedule view.
Public class TemperatureRating This class represents the definition of Conductor Temperature Rating data.
Public class TemperatureRatingType Obsolete.
Represents temperature rating type definition information.
Public class TemperatureRatingTypeSet A set that contains TemperatureRating types.
Public class TemperatureRatingTypeSetIterator An iterator to a TemperatureRating type set.
Public class VoltageType Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.
Public class VoltageTypeSet A set that contains voltage types.
Public class VoltageTypeSetIterator An iterator to a voltage type set.
Public class Wire Electrical wire element.
Public class WireConduitType Represents a specific conduit type of wire type.
Public class WireConduitTypeSet A set that contains conduit types.
Public class WireConduitTypeSetIterator An iterator to a conduit type set.
Public class WireMaterialType Obsolete.
Represents electrical wire material type definition information of wire type.
Public class WireMaterialTypeSet A set that contains wire material types.
Public class WireMaterialTypeSetIterator An iterator to a wire material type set.
Public class WireSet A set that can contain any type of object.
Public class WireSetIterator An iterator to a set.
Public class WireSize Obsolete.
Represents specific electrical wire size information.
Public class WireSizeSet A set that contains wire sizes.
Public class WireSizeSetIterator An iterator to a wire size set.
Public class WireType Represents a specific wire type.
Public class WireTypeSet A set that contains wire types.
Public class WireTypeSetIterator An iterator to a wire type set.
Enumerations
Enumeration Description
Public enumeration CableTrayShape Shape types enum of cable tray
Public enumeration CapitalizationForLoadNames Enumerated type listing the options for how electrical load names should be capitalized.
Public enumeration CircuitConnectionType An enumerated type indicates the panel to panel connection type
Public enumeration CircuitLoadCalculationMethod Methods to calculate circuit loads
Public enumeration CircuitNaming An enumerated type listing all the circuit naming options.
Public enumeration CircuitNumberingOption An enumerated type listing all the circuit numbering options.
Public enumeration CircuitSequence Options of circuit sequence for assigning circuit to circuits across panel.
Public enumeration CircuitType An enumerated type listing all the possible circuit types.
Public enumeration CoreType An enumerated type to list all core types.
Public enumeration ElectricalAnalyticalNodeType The type of electrical analytical node.
Public enumeration ElectricalCircuitPathMode An enumerated type indicates the circuit path mode
Public enumeration ElectricalConnectedPhases The electrical connected phases of an electrical analytical node.
Public enumeration ElectricalDemandFactorRule This enum describes the different demand factor rule types available to the application. Within a demand factor a rule will be referenced and the user will have to enter values corresponding to that rule.
Public enumeration ElectricalLoadClassificationData This enum is used by the ElectricalLoadClassification class as additional data whenever data members changed. It is used as the additional data when the atom corresponding to each data member is touched.
Public enumeration ElectricalLoadClassificationSpace This enum is used by the ElectricalLoadClassification to specify the load class for use with spaces.
Public enumeration ElectricalLoadType Represents the electrical load type.
Public enumeration ElectricalPhase An enumerated type to specify whether the electrical system is single phase or three phase.
Public enumeration ElectricalPhaseConfiguration An enumerated type to specify the electrical phase configuration.
Public enumeration ElectricalPhaseLine This attribute defines the electrical phase.
Public enumeration ElectricalSystemType An enumerated type listing all the possible electrical system types for a connector object.
Public enumeration LoadClassification An enumerated type to list all demand factor classifications.
Public enumeration LoadClassificationType An enumerated type listing all the possible load classification types for a connector object.
Public enumeration NeutralMode An enumerated type to list the neutral mode for wire type.
Public enumeration PanelConfiguration This enum declares the configuration for given panel schedule type.
Public enumeration PanelSchedulePhaseLoadType Declares the panel schedule type. The comments for each enum type show a simple example of how the layout would look when applied to a panel schedule
Public enumeration PanelScheduleType This enum declares the panel schedule type.
Public enumeration PowerFactorStateType An enumerated type listing all the possible power factor state types for a connector object.
Public enumeration WiringType An enumerated type to list all wiring types.