TessellatedShapeBuilderResult Class


Tessellated Shape Builder Result Class

Describes what TessellatedShapeBuilder has construct.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TessellatedShapeBuilderResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TessellatedShapeBuilderResult : IDisposable

The TessellatedShapeBuilderResult type exposes the following members.

Properties
Name Description
Public property AreObjectsAvailable Shows whether 'issues' still contains the original data or whether these data have already been relinquished by 'getGeometricalObjects'. The former is true, the later is false.
Public property HasInvalidData Whether there were any inconsistencies in the face sets, stored in the tessellated shape builder while building geometrical objects.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Outcome What kinds of geometrical objects were built.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the TessellatedShapeBuilderResult
Public method GetGeometricalObjects When called the first time, returns geometrical objects which were built. Later calls will throw exceptions.
Public method GetIssuesForFaceSet Returns the array of issues encountered while processing a face set with index 'setIndex'.
Public method GetNumberOfFaceSets Gets number of face sets for which 'this' result was obtained.
Top
See Also