ImportSizeTable Method


Family Size Table Manager Import Size Table Method

Imports a FamilySizeTable from a CSV file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool ImportSizeTable(
	Document document,
	string filePath,
	FamilySizeTableErrorInfo errorInfo
)

Parameters

document Document
Family owned document or project document.
filePath String
The CSV file path.
errorInfo FamilySizeTableErrorInfo
An error object to be written to if errors occur.

Return Value

Boolean
True if successful, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also