GetLoadForceVectorReprLine Method


Structural Settings Get Load Force Vector Repr Line Method

Returns the representative line of the load force vector according to loads display scaling.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ GetLoadForceVectorReprLine(
	LoadType loadType,
	XYZ forceVector
)

Parameters

loadType LoadType
LoadType::Point, Line, or Area
forceVector XYZ
The load force vector in internal units.

Return Value

XYZ
The the representative line in internal units.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also