ImagePlacementOptions Class


Image Placement Options Class

ImagePlacementOptions are used to describe where an ImageInstance should be placed in a view
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ImagePlacementOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ImagePlacementOptions : IDisposable

The ImagePlacementOptions type exposes the following members.

Constructors
Name Description
Public method ImagePlacementOptions Constructs a new ImagePlacementOptions that will place an ImageInstance with its center at the origin of the model
Public method ImagePlacementOptions(XYZ, BoxPlacement) Constructs a new ImagePlacementOptions for placing an ImageInstance
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Location The location in the model where a point of the ImageInstance , determined by the PlacementPoint property, is going to be inserted.
Public property PlacementPoint Identifies which point of the ImageInstance will be aligned to the Location
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ImagePlacementOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also