CanCategoryBeHidden Method


View Can Category Be Hidden Method

Checks whether the category can be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CanCategoryBeHidden(
	ElementId elementId
)

Parameters

elementId ElementId
ElementId of the category.

Return Value

Boolean
True if the category can be hidden, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Categories can be allowed to be hidden in some view types and prohibited from being hidden in others. E.g., categories cannot be hidden in ProjectBrowser
See Also