ProjectPosition Class


Project Position Class

ProjectPosition is a class used to represent a geographical offset and rotation. It can be used to represent the position of a project.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ProjectPosition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ProjectPosition : IDisposable

The ProjectPosition type exposes the following members.

Constructors
Name Description
Public method ProjectPosition(ProjectPosition) Creates a copy of the ProjectPosition.
Public method ProjectPosition(Double, Double, Double, Double) Construct a new ProjectPosition with the specified East/West offset, North/South offset, elevation offset, and angle of rotation.
Top
Properties
Name Description
Public property Angle Angle from True North.
Public property EastWest East/West offset.
Public property Elevation Elevation above ground level.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property NorthSouth North/South offset
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ProjectPosition
Top
See Also