RebarFreeFormCreationResult Class


Rebar Free Form Creation Result Class

Class that encapsulates the result of the rebar free form creation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarFreeFormCreationResult

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class RebarFreeFormCreationResult : IDisposable

The RebarFreeFormCreationResult type exposes the following members.

Properties
Name Description
Public property Error Identifies the error that occurs during the operation. Will be Success if everything is ok, otherwise the failure reason.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Rebar Identifies the created Rebar. If the error code is Success, then it will be a valid rebar, otherwise it will be a Rebar.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarFreeFormCreationResult
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also