IsInside Method (Double)


Curve Is Inside(Double) Method

Indicates whether the specified parameter value is within this curve's bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsInside(
	double parameter
)

Parameters

parameter Double
The raw curve parameter to be evaluated.

Return Value

Boolean
True if the parameter is within the bounds, otherwise false.
Exceptions
Exception Condition
ArgumentException Thrown when the specified parameter is infinite.
Remarks
Always returns true if this curve is unbound.
See Also