ParameterFilterRuleFactory Class


Parameter Filter Rule Factory Class

Contains functions that create appropriate FilterRule objects based on the parameters given.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ParameterFilterRuleFactory

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class ParameterFilterRuleFactory : IDisposable

The ParameterFilterRuleFactory type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member CreateBeginsWithRule Creates a filter rule that determines whether strings from the document begin with a certain string value.
Public method Static member CreateContainsRule Creates a filter rule that determines whether strings from the document contain a certain string value.
Public method Static member CreateEndsWithRule Creates a filter rule that determines whether strings from the document end with a certain string value.
Public method Static member CreateEqualsRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document equal a certain value.
Public method Static member CreateEqualsRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document equal a certain value.
Public method Static member CreateEqualsRule(ElementId, String) Creates a filter rule that determines whether strings from the document equal a certain value.
Public method Static member CreateEqualsRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document equal a certain value.
Public method Static member CreateGreaterOrEqualRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
Public method Static member CreateGreaterOrEqualRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
Public method Static member CreateGreaterOrEqualRule(ElementId, String) Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
Public method Static member CreateGreaterOrEqualRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
Public method Static member CreateGreaterRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
Public method Static member CreateGreaterRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document are greater than a certain value.
Public method Static member CreateGreaterRule(ElementId, String) Creates a filter rule that determines whether strings from the document are greater than a certain value.
Public method Static member CreateGreaterRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
Public method Static member CreateHasNoValueParameterRule Creates a filter rule that determines whether an element's parameter does not have a value.
Public method Static member CreateHasValueParameterRule Creates a filter rule that determines whether an element's parameter has a value.
Public method Static member CreateIsAssociatedWithGlobalParameterRule Creates a filter rule that determines whether a parameter is associated with a certain global parameter.
Public method Static member CreateIsNotAssociatedWithGlobalParameterRule Creates a filter rule that determines whether a parameter is not associated with a certain global parameter.
Public method Static member CreateLessOrEqualRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
Public method Static member CreateLessOrEqualRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
Public method Static member CreateLessOrEqualRule(ElementId, String) Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
Public method Static member CreateLessOrEqualRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
Public method Static member CreateLessRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document are less than a certain value.
Public method Static member CreateLessRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document are less than a certain value.
Public method Static member CreateLessRule(ElementId, String) Creates a filter rule that determines whether strings from the document are less than a certain value.
Public method Static member CreateLessRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document are less than a certain value.
Public method Static member CreateNotBeginsWithRule Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
Public method Static member CreateNotContainsRule Creates a filter rule that determines whether strings from the document do not contain a certain string value.
Public method Static member CreateNotEndsWithRule Creates a filter rule that determines whether strings from the document do not end with a certain string value.
Public method Static member CreateNotEqualsRule(ElementId, ElementId) Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
Public method Static member CreateNotEqualsRule(ElementId, Int32) Creates a filter rule that determines whether integer values from the document do not equal a certain value.
Public method Static member CreateNotEqualsRule(ElementId, String) Creates a filter rule that determines whether strings from the document do not equal a certain value.
Public method Static member CreateNotEqualsRule(ElementId, Double, Double) Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
Public method Static member CreateSharedParameterApplicableRule Creates a filter rule that tests elements for support of a shared parameter.
Public method Dispose Releases all resources used by the ParameterFilterRuleFactory
Top
See Also