Solid
|
Computes whether the input Solid is geometrically closed to within Revit's tolerances.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- geometry Solid
- The solid or shell geometry to test.
Return Value
BooleanTrue if the geometry is geometrically closed, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Failed to compute whether the geometry is geometrically closed. |

A solid is geometrically closed if it is topologically closed and also meets certain
geometric criteria. In particular, every pair of faces adjoining an edge must intersect
along the edge, and edge loops must have no gaps between consecutive edges of the loop,
when evaluated on the edge loop's face.
If the geometry contains multiple connected components, the function returns true
if and only if every connected component is geometrically closed. If the input Solid
contains grossly invalid geometry, an InvalidOperationException will be thrown.