SolidUtils Class


Solid Utils Class

Contains utility functions for solid operations.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SolidUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static class SolidUtils

The SolidUtils type exposes the following members.

Methods
Name Description
Public method Static member Clone Creates a new Solid which is a copy of the input Solid.
Public method Static member ComputeIsGeometricallyClosed Computes whether the input Solid is geometrically closed to within Revit's tolerances.
Public method Static member ComputeIsTopologicallyClosed Compute whether the input Solid is topologically closed.
Public method Static member CreateTransformed Creates a new Solid which is the transformation of the input Solid.
Public method Static member FindAllEdgeEndPointsAtVertex Find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.
Public method Static member IsValidForTessellation Tests if the input solid or shell is valid for tessellation.
Public method Static member SplitVolumes Splits a solid geometry into several separate solids.
Public method Static member TessellateSolidOrShell This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.
Top
See Also