MirrorElement Method


Element Transform Utils Mirror Element Method

Creates a mirrored copy of an element about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static void MirrorElement(
	Document document,
	ElementId elementToMirror,
	Plane plane
)

Parameters

document Document
The document that owns the element.
elementToMirror ElementId
The element to mirror.
plane Plane
The mirror plane.
Exceptions
Exception Condition
ArgumentException elementToMirror cannot be mirrored. -or- The element elementToMirror does not exist in the document -or- The input element is a Sketch member and there is no Sketch in the edit mode to place this element in.
ArgumentNullException A non-optional argument was null
See Also