BuiltInFailures.AnalyticalModelFailures Class


Built In Failures Analytical Model Failures Class

Failures about AnalyticalModel.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures AnalyticalModelFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static class AnalyticalModelFailures

The BuiltInFailures AnalyticalModelFailures type exposes the following members.

Properties
Name Description
Public property Static member AdjustCurveTooShort AdjustCurve is too short.
Public property Static member AdjustEdgeTooShort AdjustEdge is too short.
Public property Static member AdjustEdgeTooShortErr AdjustEdge is too short - continuable error version.
Public property Static member AdjustEdgeTooShortWarn AdjustEdge is too short.
Public property Static member AnalyticalBeamSlabWarning Beam and Slab Analytical Models do not have the same Analytical Projection Plane.
Public property Static member AnalyticalCurvedPanelNotValid Analytical Curved Panel is not valid.
Public property Static member AnalyticalDiscrepancyWarning Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]
Public property Static member AnalyticalElementsInvalidAfterUpgrade One or several analytical elements have become invalid during the upgrade process and will be deleted.
Public property Static member AnalyticalGapWarning Detected physical connection between Structural Elements, but did not detect Analytical intersection.
Public property Static member AnalyticalLinkJoinedNodes Analitycal Link is invalid. Reference nodes have been joined.
Public property Static member AnalyticalLinkNotConnected Analytical Link has lost one or more references.
Public property Static member AnalyticalMemberInstability Possible Member Instability, based on Release Conditions
Public property Static member AnalyticalModelInstability Possible Model Instability
Public property Static member AnalyticalModelIsIncorrect Analytical Model is not created for the structural element.
Public property Static member AnalyticalPanelNotPlanar Analytical Panel is not planar.
Public property Static member AnalyticalPanelNotVisible Analytical Panel is not visible in the current view.
Public property Static member AnalyticalPhysicalCheckDone Analytical / Physical Model Consistency check is complete.
Public property Static member AnalyticalSupportCycleWarning Circular support chain detected
Public property Static member AnalyticalSurfaceCannotMove Cannot move analytical surface.
Public property Static member AnalyticalSurfaceCannotMoveByConnector Cannot move analytical surface because it will disconnect the analytical nodes.
Public property Static member AnalyticalTopBottomPlanesReversed Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.
Public property Static member AutoDetectIgnoreLeaderWarning Analytical Model for Structural Element has reset to its default location.
Public property Static member BoundaryLinesIntersect Boundary lines intersect.
Public property Static member CannotCreateAnalyticalGeometry Cannot construct Analytical Geometry.
Public property Static member CannotKeepAnalyticalAdjustment Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.
Public property Static member CannotMakeAnalyticalGeometry Cannot construct Analytical Geometry.
Public property Static member CannotSlantAnalyticalWallError Cannot slant a wall with an Analytical Model. Please disable the Analytical Model first.
Public property Static member ContextualAnalyticalModelModeNotEnabled Contextual Analytical Model not enabled. File open was canceled.
Public property Static member EnterPositiveValueLessThan Please enter a positive value less than [Value].
Public property Static member HighestAssociatedLevelBelowLowestAssociatedLevel The Highest Associated Level is set below the Lowest Associated Level
Public property Static member LoadsMayBeNotUpToDate Reactions defined as Internal Load (Is Reaction) may no longer be valid since the analytical model has changed.
Public property Static member LowestAssociatedLevelAboveHighestAssociatedLevel The Lowest Associated Level is set above the Highest Associated Level
Public property Static member ProjectionPlaneInvalidWall Projection plane becomes invalid for this wall.
Public property Static member ProjectionPlanesNotIntersect Can't project Analytical Model. Planes do not intersect each other.
Public property Static member ProjectionPlanesParallel Can't project Analytical Model. Two or more projection planes are parallel.
Public property Static member StructAnalyticalErrorProjection Can't project Analytical Model to Analytical Projection Surface
Public property Static member StructuralElementMayNotBeSupported Structural Element may not be supported -- verify support for Element.
Public property Static member StructWallAnalyticalErrorAlign Can't align Analytical Model with joined Walls.
Public property Static member StructWallAnalyticalErrorConversion Can't convert Edges to Analytical Model curves.
Public property Static member SupportCheckDone Member support check is complete. No unsupported elements detected.
Public property Static member UnableToUpgradeAnalyticalElementGeometry Unable to upgrade analytical element with incorrect geometry. To keep the elements, open Revit 2022 and correct the elements.
Public property Static member WallAMLostAdjustmentReference Wall Analytical Model has lost its adjustment reference.
Top
See Also