ParameterValue Class


Parameter Value Class

A class that holds a value of a parameter element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ParameterValue
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ParameterValue : IDisposable

The ParameterValue type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Copy Makes an identical copy of the given parameter value.
Public method Dispose Releases all resources used by the ParameterValue
Public method IsEqual Tests equality with another instance of the same class.
Public method IsSameType Tests another instance is of the same value type.
Top
Remarks
This is a non-instantiable base class. Classes that actually store a value of a certain type are all derived from this base class, once class per each value type.
See Also
Inheritance Hierarchy