GetSingleConnectedAsset Method


Asset Property Get Single Connected Asset Method

Gets the single connected asset attached to this asset property, if it exists.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Asset GetSingleConnectedAsset()

Return Value

Asset
The connected asset, or if there is no connected asset.
Exceptions
Exception Condition
InvalidOperationException Asset is connected to more than one asset.
Remarks
Throws if there is more than one connected asset.
See Also