GetJoinedElements Method


Join Geometry Utils Get Joined Elements Method

Returns all elements joined to given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> GetJoinedElements(
	Document document,
	Element element
)

Parameters

document Document
The document containing the element.
element Element
The element.

Return Value

ICollection ElementId
The set of elements that are joined to the given element.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- The element element was not found in the given document.
ArgumentNullException A non-optional argument was null
Remarks
This functionality is not available for family documents.
See Also