AreaCreationData Class


Area Creation Data Class

A class which wraps the arguments of Area for batch creation
Inheritance Hierarchy
System Object
Autodesk.Revit.Creation AreaCreationData

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AreaCreationData

The AreaCreationData type exposes the following members.

Constructors
Name Description
Public method AreaCreationData(Object) Initializes a new instance of the AreaCreationData class
Public method AreaCreationData(ViewPlan, UV) The data needed to create a new area
Top
Properties
Name Description
Public property TagPoint Specify the location of the area tag.
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also