LightType Class


Light Type Class

This class encapsulates light information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LightType

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LightType : IDisposable

The LightType type exposes the following members.

Properties
Name Description
Public property ColorFilter The light filter color.
Public property DimmingColor The dimming temperature value in Kelvins.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LightType
Public method GetInitialColor Return a copy of an object derived from InitialColor
Public method GetInitialIntensity Return a copy of an object derived from InitialIntensity
Public method GetLightDistribution Return a copy of an object derived from LightDistribution
Public method GetLightShape Return a copy of an object derived from LightShape
Public method Static member GetLightType Creates a light type object from the given document and family type ID
Public method Static member GetLightTypeFromInstance Creates a light type object from the given document and element ID
Public method GetLossFactor Return a copy of an object derived from LossFactor
Public method SetInitialColor Replace the current initial color object with the given object
Public method SetInitialIntensity Replace the current initial intensity object with the given object
Public method SetLightDistribution Replace the current LightDistribution object with the given object
Public method SetLightShape Replace the current LightShape object with the given object
Public method SetLossFactor Replace the current loss factor object with the given object
Top
See Also