IsAppropriateCategoryId Method


Family Is Appropriate Category Id Method

Identifies if the input category id can be assigned as the new category for this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsAppropriateCategoryId(
	ElementId categoryId
)

Parameters

categoryId ElementId
The category id.

Return Value

Boolean
True if the input category id can be assigned as the new category for this family, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also