GetElementFilterFromRule Method (Int32, Document)


Performance Adviser Get Element Filter From Rule(Int 32, Document) Method

Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementFilter GetElementFilterFromRule(
	int index,
	Document document
)

Parameters

index Int32
The rule index to get information for.
document Document
Document for which performance problems are being checked.

Return Value

ElementFilter
The filter to restrict elements to be checked.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also