MEPSize Class |
Stores the basic size information for an MEP duct, pipe, cable tray, or conduit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MEPSize type exposes the following members.

Name | Description | |
---|---|---|
![]() | MEPSize | Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit. |

Name | Description | |
---|---|---|
![]() | InnerDiameter | Inner diameter |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | NominalDiameter | Nominal diameter |
![]() | OuterDiameter | Outer diameter |
![]() | UsedInSizeLists | Whether it is used in size lists. |
![]() | UsedInSizing | Whether is used in sizing. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the MEPSize |