ComputeIsTopologicallyClosed Method


Solid Utils Compute Is Topologically Closed Method

Compute whether the input Solid is topologically closed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static bool ComputeIsTopologicallyClosed(
	Solid geometry
)

Parameters

geometry Solid
The solid or shell geometry to test.

Return Value

Boolean
True if the geometry is topologically closed, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
A solid is topologically closed if every face has at least one edge loop and every edge is shared by exactly two faces. If the geometry contains multiple connected components, the function returns true if and only if every connected component is topologically closed.
See Also