SetFromCurvesAndShape(RebarShape, RebarBarType, RebarHookType, RebarHookType, XYZ, IList<Curve>, RebarTerminationOrientation, RebarTerminationOrientation) Method


Rebar Container Item Set From Curves And Shape(Rebar Shape, Rebar Bar Type, Rebar Hook Type, Rebar Hook Type, XYZ, IList Curve , Rebar Termination Orientation, Rebar Termination Orientation) Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetFromCurvesAndShape(
	RebarShape rebarShape,
	RebarBarType barType,
	RebarHookType startHook,
	RebarHookType endHook,
	XYZ norm,
	IList<Curve> curves,
	RebarTerminationOrientation startHookOrient,
	RebarTerminationOrientation endHookOrient
)

Parameters

rebarShape RebarShape
barType RebarBarType
startHook RebarHookType
endHook RebarHookType
norm XYZ
curves IList Curve
startHookOrient RebarTerminationOrientation
endHookOrient RebarTerminationOrientation
See Also