Rebar
|
Specify a dimension between two bends, measured by a read-only parameter.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

public void AddListeningDimensionBendToBend(
ElementId paramId,
double constraintDirCoordX,
double constraintDirCoordY,
int iSegment0,
int iEnd0,
int iSegment1,
int iEnd1
)
Parameters
- paramId ElementId
- Id of a parameter to report the length of the dimension. The parameter will be read-only on Rebar instances.
- constraintDirCoordX Double
- The x-coordinate of a 2D vector specifying the constraint direction.
- constraintDirCoordY Double
- The y-coordinate of a 2D vector specifying the constraint direction.
- iSegment0 Int32
- Index of the first segment (0 to NumberOfSegments - 1).
- iEnd0 Int32
- End (0 or 1) of the first segment.
- iSegment1 Int32
- Index of the second segment (0 to NumberOfSegments - 1).
- iEnd1 Int32
- End (0 or 1) of the second segment.

Exception | Condition |
---|---|
ArgumentException | paramId is not the id of a shared parameter in the current document, or its unit type is not Reinforcement_Length, Angle or Number. -or- The length of the vector (constraintDirCoordX, constraintDirCoordY) is too close to zero. -or- iSegment0 is not between 0 and NumberOfSegments. -or- iEnd0 is neither 0 nor 1. -or- iSegment1 is not between 0 and NumberOfSegments. -or- iEnd1 is neither 0 nor 1. |
ArgumentNullException | A non-optional argument was null |

Each reference is at the outside of the bend, perpendicular to the specified segment. So the overall length of a shape with 5 segments might be defined by calling this function with iSegment0=0, iEnd0=0, iSegment1=4, iEnd1=1.