CableType Property


Electrical System Cable Type Property

The Cable Type of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId CableType { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: The id is not a Cable Type id nor invalidElementId.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
After Cable Type of the Electrical System changes, the Cable Size will be set to InvalidElementId after regeneration.
See Also