RebarShapeId Property


Rebar Container Item Rebar Shape Id Property

The RebarShape element that defines the shape of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId RebarShapeId { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: shapeId is not the id of a RebarShape in the document. -or- When setting this property: A RebarContainerItem cannot be created from a Rebar Shape that has End Treatments or Cranks or terminations' rotation angles are different than 0.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
Changing the value of this property causes the Rebar instance to choose values for its shape parameters to preserve its previous shape as closely as possible
See Also