Rebar
|
Gets the crank straigth length taking into account the specified Rebar Crank Type.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- rebarCrankTypeId ElementId
- The Rebar Crank Type id. Interactions with Rebar Crank Types can be done with the functions in [!:Autodesk::Revit::DB::Structure::RebarCrankTypeUtils] .
Return Value
DoubleReturns the crank straigth length.

Exception | Condition |
---|---|
ArgumentException | The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category. |
ArgumentNullException | A non-optional argument was null |