ExportLineweightKey Class


Export Lineweight Key Class

A key used to represent an item stored in an ExportLineweightTable .
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportLineweightKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportLineweightKey : IDisposable

The ExportLineweightKey type exposes the following members.

Constructors
Name Description
Public method ExportLineweightKey Constructs a new default ExportLineweightKey.
Public method ExportLineweightKey(ExportLineweightKey) Constructs a new copy of the input ExportLineweightKey object.
Public method ExportLineweightKey(Int32) Constructs a new default ExportLineweightKey using the original line weight as input.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OriginalLineweight The original line weight.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExportLineweightKey
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also