Rebar
|
Identifies if the all crank parameters can be computed for the specified crank offset length and Rebar Crank Type.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

public bool CanCrankParametersBeComputedUsingCrankOffsetLength(
ElementId rebarCrankTypeId,
double crankOffsetLength
)
Parameters
- rebarCrankTypeId ElementId
- The Rebar Crank Type id. Interactions with Rebar Crank Types can be done with the functions in [!:Autodesk::Revit::DB::Structure::RebarCrankTypeUtils] .
- crankOffsetLength Double
- The value of the crank offset length to be tested.
Return Value
BooleanReturns true if the crank paramters can be computed using the input crank offset length, false otherwise.

Exception | Condition |
---|---|
ArgumentException | The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category. |
ArgumentNullException | A non-optional argument was null |