IsSameShapeIgnoringTerminations Method


Rebar Shape Is Same Shape Ignoring Terminations Method

Test whether two shapes have equivalent definitions by comparing the RebarShapeDefinition and MultiplanarDefinition properties.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool IsSameShapeIgnoringTerminations(
	RebarShape otherShape
)

Parameters

otherShape RebarShape
Another shape to be compared to this one.

Return Value

Boolean
True if the shape definitions match, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This method will return true if the definitions are exactly equivalent. The hooks, cranks, end treatments, orientations and terminations' rotation angles are ignored.
See Also