IFCParameter
|
Returns result that the proposed name is valid and not exist in the specified document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- document Document
- The document to check
- name String
- The name to check.
Return Value
BooleanWhether or not the name is valid.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Name can't contains following characters, such as { } [ ] | ; < > ? ` ~ \ : \r \n \f \t \v.
Name can't be blank.
If true, the name is valid and not exist in specified document.
If false, the name is not a valid name which means it does not exist in specified document.