LoadComponent Class


Load Component Class

An object that represents a load combination component.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure LoadComponent

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LoadComponent : IDisposable

The LoadComponent type exposes the following members.

Constructors
Name Description
Public method Code example LoadComponent Constructs a new instance of a LoadComponent. The load case or combination id. The load case or combination factor.
Top
Properties
Name Description
Public property Factor Load component factor.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LoadCaseOrCombinationId Load case or combination id.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LoadComponent
Top
See Also