IExportContextBase Interface


IExport Context Base Interface

An interface that as common base for IModelExportContext and IExportContext2D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IExportContextBase : IExportContext

The IExportContextBase type exposes the following members.

Methods
Name Description
Public method OnCurve This method is called when a Curve is being output.
Public method OnLineSegment This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

Public method OnPolyline This method is called when a Polyline is being output.
Public method OnPolylineSegments This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

Public method OnText This method is called when a text annotation object is being output.
Top
See Also